実際に体験した訳では無いのですが、IE8でWordPress3.5のダッシュボードにアクセスした際、何か問題は無いかと調べていたところ、下記を見つけました。

wordpress.orgのフォーラム
[closed] WordPress 3.5 upgrade causing issues on some Internet explorer browsers
http://wordpress.org/support/topic/wordpress-35-upgrade-causing-issues-on-some-internet-explorer-browsers?replies=7

WordPress3.4.2を3.5にアップデートしたところ、IE9以下では表示が乱れ、wpbakery visual editorもまったく動作しないとのこと。

解決方法が下のほうに書かれていて、header.phpの1行目を以下に書き換えたところ、解決しようです。

<meta http-equiv=”X-UA-Compatible” content=”IE=edge” >

これはIEに対して互換表示ボタンを非表示にし、最上位バージョンで動作するように指示しているとのことです。

Yukawa